Re: [keycloak-user] Issue running Angular 2 JS example using Keycloak

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [keycloak-user] Issue running Angular 2 JS example using Keycloak

Tom Jackman
Hi,

I am also seeing this issue with Angular and the Ionic Framework. Anyone
with ideas on how to fix this would be greatly appreciated.

Thanks.
Tom.




On 19 May 2017 10:03 am, "Kiran Kumar" <[hidden email]>
wrote:

Hi,

The angular 2 example provided in keycload demo 3.1.0.Final works fine if
it deployed angular app on Wildfly server. In this scenario both keycloak
and angular 2 app are running on default port 8080. But the same doesn't
work if angular 2 app is deployed on different for example port 4200 using
'ng serve' command. I have updated settings 'Valid Redirect URIs', 'Base
URL' and 'Web Orgins' to use 4200 port in keycloak admin console for
angular 2 app. The issue is first time on accessing the application the
login page is presented. After entering the credentials it keeps
redirecting in infinite loop. This issue appears both in Chrome and Firefox
browser.

I have raised this question on stack overflow. The link for this is

https://stackoverflow.com/questions/44058886/issue-
running-angular-2-js-example-using-keycloak

Kind Regards,
Kiran

This email has been scanned by Symantec
_______________________________________________
keycloak-user mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/keycloak-user
_______________________________________________
keycloak-user mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/keycloak-user